文章出處

 

Sticks
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 129606   Accepted: 30388

Description

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

Input

The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

Output

The output should contains the smallest possible length of original sticks, one per line.

Sample Input

9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0

Sample Output

6
5

 

 

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int a[70], n;
bool vis[70];
int Cmp(int a, int b)
{
    return a>b;
}

//len 是要構造的每段的長度。 cur是構造每段
//長度的過程中還需要的。 num是剩余的木棒數。 
int dfs(int len, int cur, int num)
{
    if(cur==0&&num==0) return true; 
    if(cur==0) cur = len;
    for(int i=0; i<n; i++)
    {
        if(vis[i]) continue;
        if(cur-a[i]>=0)
        {
            vis[i] = 1;
            if(dfs(len, cur-a[i], num-1)) return true;
            vis[i] = 0;
            if(a[i]==cur||cur==len) return false;//a[i]==cur
//滿足一個木棒長度, 但是不滿足全部的 cur==len是進行循環之后還是不滿足 
            while(a[i]==a[i+1]&&i+1<n) ++i;
        }
    }
    return false;
}

int main()
{
    while(scanf("%d", &n), n)
    {
        int sum = 0;
        for(int i=0; i<n; i++)
        {
            scanf("%d", &a[i]);
            sum+=a[i];
        }
        sort(a, a+n, Cmp);
        for(int i=a[0]; i<=sum; i++)
        {
            if(sum%i==0)
            {
                memset(vis, 0, sizeof(vis));
                if(dfs(i, 0, n))
                {
                    printf("%d\n", i);
                    break;
                }
            }
        }
    }
    return 0;
}

 


文章列表


不含病毒。www.avast.com
arrow
arrow
    全站熱搜
    創作者介紹
    創作者 大師兄 的頭像
    大師兄

    IT工程師數位筆記本

    大師兄 發表在 痞客邦 留言(0) 人氣()